Quest Diagnostics: Elevated Error Rate
Incident Report for Atlas.md
Resolved
This incident has been resolved.
Posted over 2 years ago. Mar 30, 2017 - 11:32 CDT
Monitoring
Quest Diagnostics reports that the problem is fixed on their servers and that the ordering system should be back to normal. We're monitoring this for the next hours to make sure the problem has been solved.
Posted over 2 years ago. Mar 30, 2017 - 07:56 CDT
Identified
Quest Diagnostics has identified the problem on their end. They're currently working to find a solution.
Posted over 2 years ago. Mar 29, 2017 - 15:36 CDT
Investigating
Quest Diagnostics's ordering system is showing an elevated error rate. We've been working with Quest to stabilize the situation.
Posted over 2 years ago. Mar 29, 2017 - 09:22 CDT