Quest Diagnostic's Partial Outage
Incident Report for Atlas.md
Resolved
Quest is back to full stability and all of its services are working as expected.
Posted almost 4 years ago. Oct 17, 2015 - 06:31 CDT
Monitoring
Quest is experiencing some instability today, particularly when requesting new orders. This is an intermittent problem that's affecting most but not all new lab requests. We're monitoring the problem from our end. (The issue is related to placing new orders; results are not affected and are being delivered normally.)
Posted almost 4 years ago. Oct 16, 2015 - 16:42 CDT